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1. はじめに

本書は、Schrodingerを東京工業大学学術国際情報センターの TSUBAME3 で利用する方法について説明しています。 また、TSUBAME3 を利用する

にあたっては、TSUBAME利用の手引きもご覧下さい。 利用環境や注意事項などが詳細に記述されております。

1.1. 利用できるバージョン

TSUBAME3で利用可能な最新バージョンについてはTSUBAME計算サービスWebサイトの アプリケーション ページをご確認下さい。

研究に支障がない限り、バグ修正の入っている最新版をご利用下さい。

1.2. 概要

SMALL-MOLECULE DRUG DISCOVERY SUITEは低分子創薬向けモデリング/シミュレーションソフトウェア群です。

SMALL-MOLECULE DRUG DISCOVERY SUITEの主なプログラムを以下に示します。 赤字はインストールはされプログラム自体は存在しますが、ライ

センスがないため実行できないプログラムとなります。
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製品 説明

ADME 仮想毒性試験ツール

AutoQSAR QSAR予測モデルの自動生成と解析ツール

BioLuminate バイオ医薬品創出やタンパク質モデリングソフトウェア

Canvas ケモインフォマティックス・コンピューティングの統合環境

CombiGlide リード化合物の探索や最適化のための、コンビナトリアル分子構造生成とコアホッピングツール

ConfGen 効率的な生理活性コンフォメーション探索ソフトウェア

Core Hopping リガンド構造やリガンド?受容体複合体構造に基づいた、リード最適化のための網羅的な母核探索ツール

CovDock 共有結合リガンドの結合ポーズ予測とドッキングスコアを算出するオールインワンのワークフローツール

Desmond 高速分子動力学シミュレーションソフトウェア

e-Pharmacophores エネルギー的に最適化した受容体構造ベースの3Dファーマコフォア生成ツール

Epik 高速で信頼性の高いpKa予測ソフトウェア

FEP+ 新規医薬品創出を目的とした高性能な自由エネルギー摂動計算ソフトウェア

Field-Based QSAR リガンド構造に基づいた定量的構造活性相関による新規リード化合物探索、最適化ツール

Glide リガンド-受容体ドッキングソフトウェア

Impact Glideにて利用されるMD計算ツール

Induced Fit 受容体活性サイト内のインデュースドフィット（誘導適合）を考慮した、正確で高速なドッキング手法

Jaguar 高速ab initio量子化学計算パッケージ

KNIME Extensions ワークフロー自動化とデータ解析を簡単に行うための、柔軟な設定が可能で多彩なモジュールを持つフレームワー

ク

LigPrep さまざまな用途で利用可能な正確な3D分子モデル生成ツール

MacroModel 多様な研究に対応するフル機能を備えた分子モデリングプログラム

Maestro 汎用分子モデリング環境

MMLIBS Maestroなどで利用されるライブラリ群

OPLS 高精度力場

Phase リガンド構造に基づいたドラッグデザインのための高性能プログラム

PLDB 高い拡張性を持った、タンパク質の三次元構造およびタンパク質?リガンド相互作用のデータベース

Prime 高精度タンパク質構造予測プログラムパッケージ

PrimeX 正確なタンパク質結晶構造リファインメントを行う包括的なパッケージ

Protein Preparation

Wizard

シミュレーションに適したタンパク質構造の調整を行い、信頼性の高いall-atomのモデル構造を作成するための使

いやすいツール

QikProp 医薬品候補化合物探索のための高速ADME特性予測

QM-Polarized Docking Glideの性能とQSiteの正確性を組み合わせた、新しい研究のソリューション

QSite 高速QM/MMプログラム

Shape Screening 分子形状に基づき構造の重ね合わせと類似性検索を行う、高速で効率的なツール

SiteMap 精度と高速性を兼ね備えた実用的なリガンド?受容体結合部位の同定ツール

WaterMap タンパク質のリガンド結合サイトにおける水和構造と、その水分子のエネルギー的な特性の予測ツール
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1.3. マニュアル

Maestro起動後にHELP>HELPより確認したい項目のマニュアルを参照ください。
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2. SMALL-MOLECULE DRUG DISCOVERY SUITEの使用方法

2.1. SMALL-MOLECULE DRUG DISCOVERY SUITEの利用の流れ

SMALL-MOLECULE DRUG DISCOVERY SUITEを利用する場合は大きく分けて、Maestro、Canvas、Knimeのいずれかの統合環境を利用して計算を行

う場合とコマンドラインで直接、各種計算プログラムを叩く場合の2種類がございます。 また、統合環境を利用する場合は、TSUBAME3にインス

トールされたものを利用する場合と、クライアント側にインストールを行い、計算をクライアント側で行う、もしくは計算のみTSUBAME3または

研究室内の計算サーバに投入する場合が考えられます。 接続設定の詳細はインストール手順書に記載しておりますのでご確認ください。

本書ではライセンス数の多いMaestroを利用した利用方法とコマンドラインでの投入についてご説明します。

2.2. SMALL-MOLECULE DRUG DISCOVERY SUITEのコマンドライン実行

2.2.1. インタラクティブ実行

ログイン方法を参考にログインノードにログイン後、インタラクティブノードを利用したX転送を参考にノードをX転送付きで確保して下さい。 以

下以降の例では、全て計算ノードにログインした状態で行います。

2.2.1.1. CUIでの実行

以下はあくまでもコマンドサンプルです。実際の計算には入力ファイルが必要となります。

Ligprepのインタラクティブ処理を以下に示します。

2.2.1.2. GUIでの実行

GUIの場合は以下の方法で実施してください。 

コマンド実行例

例では2時間接続で、割り当てノードとしてr0i0n0が割り当てられた場合を想定しております。

割り当てノードはコマンド実行時に空いているノードですので、明示的にノードを指定することはできません。

$ cd <利用したいディレクトリ>

SMILES形式の入力ファイルを使用し，MAE形式で出力する場合

$ ligprep -ismi<入力ファイル> -omae<出力ファイル>

#qrshの実行

$ qrsh -g [TSUBAMEグループ] -l f_node=1 -l h_rt=2:00:00

Thu Sep 21 08:17:19 JST 2017

r0i0n0:~>

r0i0n0:~> . /etc/profile.d/modules.sh

r0i0n0:~> module load schrodinger/Feb-17

r0i0n0:~> maestro

*****************************************************************

Maestro Molecular Modeling Interface

Maestro is a product of Schrodinger, Inc.

Legal notices can be viewed by clicking Help->About Maestro

*****************************************************************
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maestroの起動画面

エラーが発生する場合は-hオプションを付けて実行し、表示されるヘルプを見て、環境に合わせた実行を行ってください。

maestroの画面

メニューバーの File > Quit をクリックすると終了します。
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2.2.2. バッチジョブスケジューラーUGEによる実行

以下はあくまでもコマンドサンプルです。実際の計算には入力ファイルが必要となります。

スクリプト例：Ligprep

2.2.3. ライセンス数

ライセンス数や利用状況については下記コマンドで確認してください。

現在契約しているライセンス数については下記のページをご確認ください。

https://www.t3.gsic.titech.ac.jp/node/8

#!/bin/bash

#プライオリティ

#$ -p -5

#実行ディレクトリ：カレントディレクトリ

#$ -cwd

#$ -N sc_serial_test_job #job名

#送信先メールアドレス

#$ -M ambertest[at]o.cc.titech.ac.jp

#エラーメッセージファイル名、設定なしだとスクリプト.e.JOBID

#$ -e uge.err

#標準出力ファイル名、設定なしだとスクリプト.o.JOBID

#$ -o uge.out

#*必須：資源タイプの指定

#$ -l q_core=1

#*必須：時間指定

#$ -l h_rt=0:10:00

#$ -V

#モジュールの呼び出し

. /etc/profile.d/modules.sh

module load schrodinger/Feb-17

# ligprepの実行

# Maestroで作成したSMILES形式の構造ファイルとしてtest.msi、出力をSDF形式、ファイル名をtest_ugeout4.sdfとするligprep計算の例

# 計算ごとの対応形式については1.3より詳細をご確認ください。

ligprep -ismi test.smi -omae test_ugeout4.sdf -TMPDIR $TMPDIR

$ lmutil lmstat -S SCHROD -c 27010@lice0:27010@remote:27010@t3ldap1
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3. Maestroの利用方法

3.1. Maestroの概要

MaestroはSchrodinger Suiteを利用する上で分子モデリングや解析が可能な統合GUI環境です。 計算化学の専門家だけでなく、現場のメディシナル

ケミストにも使いやすいように工夫されており、3次元QSARを行う「Phase」や化合物ライブラリーを扱う「CombiGlide」の一部機能の統合され、

簡易解析であればMaestroのみで実行できます。 またジョブの投入機能もあるため、Maetroで作成したシステムをTSUBAME3に投入し計算を行う

ことも可能です。

3.2. TSUBAME3上のMaestroの起動

下記コマンドでTSUBAME3にログインしてください。

インタラクティブジョブを投入します。例はお試し実行となります。 

下記コマンドでモジュールファイルを読み込んでください。

下記コマンドでMaestroを起動します。

$ ssh login.t3.gsic.titech.ac.jp -l USER-ID -i 鍵ファイル -YC

$ qrsh -l s_core=1,h_rt=600

$ module load schrodinger

$ maestro
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利用しているX環境によってはエラーが発生する場合があります。その場合は以下コマンドを実行し、ヘルプを表示させ、環境に合わせたオプショ

ンを指定し、実行してください。

3.3. Maestroの画面説明

メインメニューは詳細な機能を提供するためのアクセスポイントです。機能の概要については下記の通りです。

3.3.1. メインメニュー

メインメニュー

メインメニューの機能

3.3.2. ワークスペース

ワークスペースはリガンドなどの低分子構造やタンパク質の立体構造などといった中～大規模分子構造を可視化する領域です。

$ maestro -h

項目 機能

Maestro Macのみ: 標準的なアプリケーションメニュー

File すべてのプロジェクトおよび構造に関する終了を含むアクション

Edit 構造とエントリの変更に関連するアクション。 アプリケーションの設定もここに含みます。

Select 選択に関連するアクション

Workspace ワークスペースの内容に関連するアクション。 外観設定も含まれます

Scripts ユーザー定義のスクリプトとKNIMEワークフローのアクセスポイント。

View カメラビューを変更する、ビューを保存する、画面の表示を変更するアクション。

Window フローティングウィンドウ、ペイン、ガジェットトグルのアクセスポイント。

Help ヘルプ、キーボードショートカット、チュートリアルなどへのアクセス。テクニカルサポートへのアクセスとライセンス

とホストの設定ダイアログへのアクセスも含まれています。
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ワークスペース

3.3.3. ツールバー

ツールバー

ツールバーはMaestroの主要ツールでワークスペース中のオブジェクトを選択して操作することができます。

ツールバーには、ワークスペース内のオブジェクトを選択する2つの方法があります。ピッキングツールか、簡易選択機能です。 ピッキングツール

は、ワークスペース内の原子、結合、またはリボンをクリックするか、領域をドラッグして囲まれたオブジェクトを選択できます。 クイックセレ

クト機能では、共通構造オブジェクトまたは定義したカスタムセットリストから選択できます。 選択を変更する他の方法のボタンもあります。 

ピッキングツール

ピッキングツール

ピッキングツールは、ワークスペースのオブジェクトを選択する主な方法です。 ピッキングツールは、ウィンドウの左上にあります。 アクティブ

にすると矢印が青色に変わり、オブジェクトをクリックまたはドラッグするとアクティブな選択が変わります。 結合をクリックして結合内の2つの

原子を選択するか、リボンをクリックして関連する残基のアルファ炭素を選択することもできます。

ピッキングモードは3つあり、デフォルトのモードは標準ピッキングで、選択したオブジェクトのみが選択状態になり、他のすべてのオブジェクト

は選択解除されます。 他の2つのモードは、ピッキングツールの隣のボタンでアクティブになります。
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選択追加アイコン

＋マークをクリックすると、ワークスペースまたは選択ツールバーでクリックしたオブジェクトが現在の選択範囲に追加されます。

選択削除アイコン

－マークをクリックすると、ワークスペースまたは選択ツールバーでクリックしたオブジェクトが現在の選択範囲から削除されます。

ロック表示

ポインタアイコンが鍵のようなアイコンに変わる場合はオブジェクトがロックされたエントリにあり、選択できないことを示します。 ロックされ

たエントリ内のオブジェクトを選択することはできません（測定モードなどを除いて、アクションが許可されません）。 

ピッキングレベルメニュー

ピッキングレベルメニュー

ピッキングレベルメニューは、ワークスペースで選択する内容を決定します。 デフォルトでは、原子選択です。 より高いレベルでは、単一の原子

をクリックすると、関連するすべてのオブジェクト（関連する残基、鎖、分子、またはエントリ）が選択されます。

予測ハイライト

予測ハイライト表示

Schrodinger 利用の手引き

- 13/47 - 2023-12-29



左が硫黄の上にポインタを動かした場合の表示、右がポインタを硫黄から離した表示

予測ハイライトは、クリックするとどのオブジェクトが選択されるかを示します。 オブジェクトの上にポインタを置いて、どのオブジェクトが

「点灯」しているかを確認します。 

簡易選択機能

簡易選択機能　アイコン

ワークスペース内の特定の種類の一般的なオブジェクトのワンクリック選択を提供します。 ボタンは下記の通り

アイコンの機能

拡張選択機能 

拡張選択機能

アイコンの機能 

アイコン 機能

タンパク質選択

リストからの選択

リガンド選択

全選択

溶媒選択

選択解除
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画面調整ツール

画面調整ツール

ワークスペースのズーム/ズームアウトを変更します。

アイコンの機能

スタイルツールボックス

スタイルツールボックス

アイコン 機能

選択反転

一つ前の選択に戻します

選択範囲の距離指定を行います。各種オプションがあります。

カスタム選択機能を提供します

アイコン 機能

全オブジェクトがワークスペース内に自動的に収まるよう設定されます。

リガンドがワークスペース内に自動的に収まるよう設定されます。

表示されている全オブジェクトが自動的に収まるよう設定されます。

選択したオブジェクトがワークスペースビュー内に自動的に収まるよう設定されます。

LIGANDボタンと似た機能ですが、クリックするたびに個々のリガンドにフォーカスされます。
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アイコンの機能
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アイコン 機能

オブジェクトの可視

CPK表示

オブジェクトの不可視

色変更ツール

選択オブジェクトのみ可視

単色変更ツール

水素の可視/不可視

ラベルツール

線モデル

ラベル除去ツール

棒モデル(細)
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プリセットスタイルツール

プリセットスタイルツール

プリセットスタイルの分割ボタンの左側がカスタムプリセットを適用します。 右の矢印は、事前入力済みのPyMOLスタイルのプリセットとプロ

ファイルのデフォルトのプリセットを含むメニューを開きます。

アイコン 機能

リボンツール

棒モデル(中)

リボン除去ツール

棒と丸モデル

表面ツール
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ビルダー

ビルダー

3Dビルダーパネルは、主要な構造編集および構築ツールです。直接作業し、原子や結合を選択して削除したり、追加したり、プロパティを変更す

ることができます。 このパネルは、ワークスペースの上のBUILDボタンをクリックすると開き、パネルは手動で閉じるまで開いたままで、常にメイ

ンウィンドウの上にあります。

アイコンの機能
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アイコン タイプ 機能

エントリの作成 新規エントリの作成

エントリの作成 エントリの複製

エントリの作成 新規エントリを作成し、選択オブジェクトをコピーする

エントリの作成 新規エントリを作成し、選択オブジェクトを移動する

基本編集 原子や結合の削除

基本編集 元素指定

基本編集 結合の削除

基本編集 結合の作成

基本編集 +1電荷を追加

本編集 -1電荷の追加
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カメラの変更

カメラの変更メニュー

オブジェクト選択中に［SPACE］キーを押すことで表示を変更することができます。 ［SPACE］キーをおしたまま各アイコンをクリックし、ド

ラッグすることでアイコンに応じた変更を行うことができます。

アイコンの機能

アイコン タイプ 機能

基本編集 結合の追加(三重まで)

基本編集 結合の除去(0まで)

移動と構築 選択したオブジェクトを指定した方法で移動させます。詳細はクリックした際に表示される

バナーを参照してください。

移動と構築 選択したオブジェクトにフラグメントを追加するためのパレットを開き、選択がない場合は

ワークスペースに配置します

移動と構築 ワークスペース内のオブジェクトを描画または消去し、既存のオブジェクトの要素を変更す

る機能です。バナーには、手順と一連のツールが用意されています

移動と構築 選択した原子に水素を追加します。

移動と構築 選択したオブジェクトの最適化を行います。
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フラグメントメニュー

フラグメントメニュー

この小さなアイコンは、新しく追加された各フラグメントの横に表示され、関連のない操作が行われるまでワークスペースに残ります。 アイコン

をクリックすると、新しいフラグメントで使用可能なアクションのメニューが開きます。

プロジェクトパネル 

これら2つのボタンを使用すると、プロジェクト関連のパネルを表示できます。 上のボタンはプロジェクトテーブルの表示、下のボタンはワークス

ペースナビゲータパネルを表示します。

アイコン 機能

回転

移動

ズーム/ズームアウト
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プロジェクトテーブル

ジョブステータスアイコン

ジョブステータスアイコンは、ジョブの実行、失敗、または完了を示します。 また、アクティブなジョブをリストし、ジョブモニタパネル全体に

アクセスできる小さなミニモニタパネルへのアクセスも可能です。 アイコンの表示別の状態は下記の通りです。

アイコンの機能
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タスクツール

タスクツール

タスクツールはMaestroに含まれているすべてのアプリケーションとツールのアクセス環境です。

アプリケーションへのアクセスを助ける検索、ブラウズ、ショートカット、お気に入りなどの機能があります。

3.3.4. ワークスペースナビゲータ

アイコン 機能

デフォルト状態

現在実行中のジョブはなく、最近完了したジョブもありません。

計算中

このプロジェクトで現在少なくとも1つのジョブが実行されています。 クリックすると、ミニモニタペインにアク

ティブなジョブのリストが表示されます。 ジョブの詳細については、表の行をダブルクリックして、モニターパ

ネルでジョブを表示してください。

計算完了

現在実行中のジョブはありませんが、1つ以上のジョブが正常に完了しました。 クリックしてミニモニタを開き、

Incカラムをクリックしてジョブの結果を組み込む事ができます。最近完了したジョブの詳細について「モニタ」

ボタンをクリックします。

失敗

このプロジェクトの少なくとも1つのジョブがエラーで失敗しています。 このステータスは他のすべてのものを上

書きします。クリアするには、ミニモニタを開き、ピンクの背景とステータスが「died」ジョブを探します。

テーブルの行をダブルクリックすると、モニタパネルでジョブの詳細が表示されます。 その後、ステータスが

「失敗」に変わり、ミニモニタペインを閉じた後、ジョブボタンが通常の状態に戻ります。
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ワークスペースナビゲータ

ワークスペースナビゲータは、エントリリストと構造階層の2つの部分で構成される単一のパネルで構成され、エントリを管理し、ワークスペース

内の構造を管理するために使用されます。 エントリリストは、以下を提供するプロジェクトテーブルのサブセットです。

ワークスペースに構造を描画する

タスクのエントリ行の選択・管理

複製、分割、マージによる新しいエントリの作成

階層内のエントリのグループ化とグループ解除

エントリの削除

構造階層は、ワークスペースに含まれる構造と下位構造をで表現されます。 

エントリ階層

• 

• 

• 

• 

• 
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エントリ階層

エントリ階層は、グループ内でグループを作成できるようにすることで、柔軟な方法でエントリを整理する機能を提供します。 ワークスペースナ

ビゲータの一部であるエントリリストとプロジェクトテーブルパネルの両方が階層を最大限に活用します。 

構造階層

構造階層

構造階層は、現在ワークスペースに含まれているエントリの階層ビューを提供します。 これにより、各レベルの構造を操作して、ツリーの各行の

可視トグル、スタイリングツールボックス、および原子選択機能を提供します。

3.3.5. フッターバー
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フッターバー

ワークスペースの下部にあるフッターには、ステータスバーとワークスペース設定ツールバーが含まれています。 ステータスバーには、ワークス

ペース内の構造に関する情報が表示されます。 ワークスペース設定ツールバーでは、どのような補助オブジェクトが表示されるかを判断すること

ができます。 また、ワークスペースを強化するさまざまなガジェットやツールにアクセスすることもできます。 

ステータスバー

ステータスバー

ステータスバーの左側の固定された領域には、ワークスペース内の選択、表示ならびに合計の原子数が表示されます。 これらの値は、選択が変更

されると下記のように情報が更新されます。

ある残基の炭素を選択した場合の表示

ワークスペースコンフィグレーションツールバー

ワークスペースコンフィグレーションツールバー

ワークスペースコンフィグツールバーには、ワークスペースで現在利用可能な補助オブジェクトを一時的に非表示にできるトグルボタンがありま

す。 オブジェクトが使用可能で、ワークスペースに表示されているときは、ボタンが青色になります。 利用可能な場合は透明な背景となり、利用

できないときはくすんだ青色となります。 それらの中にはツールボックスやパネルを開くためのボタンがあります。

アイコンの機能
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インタラクションツールボックス

インタラクションツールボックス

このツールボックスでは、3種類の結合されていない相互作用の表示/非表示を切り替えることができます。 それぞれのサブタイプには、個別に切

り替えることもでき、サブタイプの状態を保持しながら、基本的な対話タイプを隠すことができます。 これらのインタラクションタイプのそれぞ

れには、インタラクションに使用する原子セットを選択できるメニューもあります。 すべての場合において、デフォルトはリガンド受容体です。 

アイコン 機能

ラベル表示

メジャー表示

表面表示

リボン表示

インタラクションツールボックスの起動

ワークスペースコンフィグレーションツールボックスの起動
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ワークスペースコンフィグレーションツールボックス

ワークスペースコンフィグレーションツールボックス

ワークスペースコンフィグレーションツールボックスは、ワークスペースとMaestroの追加機能のレイアウトオプションを統合します。 各項目はア

イコンをクリックすることでオンオフすることができ、オンにするといくつかのオプションが追加されます。 

測定ツールボックス

このツールボックスには、ワークスペースに現在表示されている各測定タイプのタブが含まれています。 測定のマーカーの色は、タブラベルの隣

に表示されます。パネル内の測定行をダブルクリックしてワークスペースをその測定値に合わせるか、右クリックして次のアクションを含むコンテ

キストメニューを開くことができます。

ワークスペースに合わせる - ワークスペースを測定に合わせる（測定を拡大する）

削除 - 測定値を削除する

Calculate Property - 測定内の原子を使用して、選択した各エントリの測定プロパティを作成します。これは、原子番号を使用するので、主にコ

ンホーマーに有用です。

• 

• 

• 
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Calculate Property

パネルの右上隅にある矢印ボタンは、現在表示されているタブの測定値の削除とエクスポートアクションだけでなく、すべての測定値の削除を提供

します。 エクスポートでは現在のタブに測定値を含むプレーンテキスト（CSV）ファイルが書き込まれます。 矢印の左にあるルーラーボタンは、

ワークスペースを測定モードにし、ツールボックスを閉じます。

3.3.6. ワークスペースガジェット

2Dオーバーレイ表示

2Dオーバーレイ表示

ワークスペースガジェットは、任意のリガンドまたは他の小分子の2D版をワークスペースに表示します。

ペインを右クリックしてメニューを開きます。 単一の構造のみが表示されている場合は、2Dスケッチャーで構造を開くオプションが含まれます。

ワークスペースプロパティ
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このワークスペースガジェットは、左上隅に表示され、ワークスペース内の「ターゲット」エントリの選択されたプロパティ情報を表示します。

ポインタが画面のこの領域に移動すると、ポインタが手書きアイコンに変わり、ポインタがガジェット内にあることを示します。 クリックすると

Change Workspace Propertiesダイアログが開きます。 このダイアログボックスでは、このエリアに表示されているプロパティのリストを追加、削

除、並べ替えができます。 右クリックすると、このダイアログを開くことができるメニューが表示され、プロパティを非表示にできます

3.3.7. ワークスペースメニュー

ワークスペースにはいくつかのショートカット（コンテキスト）メニューがあり、その内容はクリックするオブジェクトによって異なります。 こ

れらのメニューについては、以下で簡単に説明します。 メニューの詳細はメインウィンドウのショートカットメニューにあります。 

選択した原子及び結合のショートカットメニュー

選択した原子及び結合のショートカットメニュー 左:原子、右：結合

ワークスペース内のアトムまたはボンドを右クリックすると、選択したショートカットメニューが表示されます。 アクションは、メニュータイト

ルで示されるように、選択された原子または結合の数によって異なります。 適用可能な場合は、測定や調整が可能です。

表面のショートカットメニュー

表面のショートカットメニュー

ワークスペース内の表面を右クリックすると、このメニューが表示されます。 表示オプションは、表面の名前を変更するためのダイアログを開き

ます。 ワークスペースに現在含まれているすべての表面が表示されているかどうかを示すダイアログが開きます。

3.4. Maestroによる計算投入

ここではMaestroのチュートリアルにあるデータを利用してMaestroからLigprepの計算を行います。

maestroが起動している前提ですすめます。

Maestroで作成したファイルを使ってqsubで投入する場合は2.2.2. バッチジョブスケジューラーUGEによる実行をご確認ください。
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3.4.1. 計算用データの取得

計算用のデータを取得をするため、チュートリアルデータにアクセスします。 

チュートリアルの呼び出し

Help>Tutorials…を選択します。 

チュートリアルダイアログ
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チュートリアルダイアログが起動するので、filterにligprepと記入します。 

チュートリアルダイアログ　Filter by ligprep

ligprepのデータのコピーを行うため、Copy to:にコピー先のディレクトリを直接記入するか、Browse…から指定し、「Copy…」ボタンをクリックし

ます。

環境によっては一瞬でコピーが終了しますので、念のためlsコマンドなどで確認してください。

(日本語ディレクトリなど2バイト文字を含むディレクトリがあるなどの場合はBrowse…クリック時にMaestroが異常終了する場合が ります。

その場合はOS環境を英語環境に変更してください。)

例では/home//schrodingerにコピーしております。

下記コマンドを打ち、ファイルが有ることを確認して下さい。 

3.4.2. ファイルの読み込み

コピーしたファイルを読み込んで、構造を確認します。 

ファイルの読み込み＠メニュー

file＞Import Structureを選択してください。 

$ ls

1D_smiles.smi  2D_variations.sdf  3D_rings.mae  examples.sdf
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コピーしたディレクトリから1D_smiles.smiを選択し、Openをクリックしてください。

今回は確認のため、ProjectTableによる確認を行います。 
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ProjectTableの呼び出し

Window>ProjectTableを選択してProjectTableを呼び出します。 
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ProjectTable

74化合物存在することを確認し、2D viewerアイコンをクリックして各構造についても確認します。 
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2D viewer 

確認したら2D viewer、ProjectTableを閉じて構いません。

3.4.3. ジョブの作成

タスクツールからLigprepを呼び出します。

メニューに表示されている場合はそのまま選択し、ない場合はSearch欄に「Ligprep」と打ち、Ligprep＞Ligprep…をクリックします。 
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Ligprepの選択(メニューから選択)

Ligprepの選択(検索メニューから選択)
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Ligprepジョブダイアログ

Ligprepジョブダイアログが表示されるので、今回は先程読み込んだProjectTableを元に計算を行います。図は指定した後の画面です。

今回はその他の項目についても図のように指定してください。 

指定可能なパラメータについては各自にて？ボタンよりマニュアルを呼び出し、確認してください。

3.4.4. ジョブの投入先の指定

ジョブができたら、投入先の指定を行います。

歯車状のジョブダイアログアイコンをクリックしてください。 

ジョブセッティングダイアログアイコン
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ジョブセッティングダイアログ(ユーザ端末上)

上記のジョブセッティングダイアログが表示されますので、localhostを指定し、資源タイプに合わせてCPU数などを設定してださい。 

3.4.5. ジョブの投入と確認

LigprepジョブダイアログもしくはジョブセッティングダイアログのRunボタンをクリックすると計算サーバに投入されます。

ここではLigprepジョブダイアログから投入しますので、ジョブセッティングダイアログは閉じ、LigprepジョブダイアログからRunボタンをクリッ

クしてください。 

ジョブ投入直後のLigprepジョブダイアログ

ジョブ投入直後にSubmitting Job…の表示に切り替わります。 

バッチジョブスケジューラーに投入された後のLigprepジョブダイアログ

バッチジョブスケジューラーに投入されるとJob startedの表示になりますが、qw状態でもこの表示になります。 

Maestroのジョブダイアログ：計算中

Maestroでもジョブが流れていることを確認できます。 
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ミニジョブモニター起動ボタン

ミニジョブモニター起動ボタンをクリックすると、ミニジョブモニターが立ち上がります。 

ミニジョブモニター

すでに計算が終了している場合はミニジョブモニターに何も表示されません。

計算が終了していない場合や、異常終了している場合はここに情報が表示されます。

表示されていない場合はMoniter…をクリックしてジョブモニターで計算の状態を確認する必要があります。 
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ジョブモニター

ジョブモニターでは詳細なジョブの情報を確認することができます。

例ではcompleted：finishedとなっており、正常終了しております。 

completed：finishedの状態でジョブ欄をクリックするとincorporatedに変化します。

この状態になるとデータがProjectTabeleの組み込まれているので、データを確認します。 
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ProjectTabele によるLigprepの計算後のデータ確認

ProjectTabeleを起動し、データを確認します。

例ではligprep_1-out1というSDFファイル中に90個の化合物が存在します。 

3.4.6. 結果の保存

メニューより、File>Save Project As…を選択します。 

Projectの保存方法
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Projectの保存

Projectの保存ダイアログが表示されますので、Flie名を指定して保存してください。
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改訂履歴

改定日付 内容

2021/08/25 「2.2.2. バッチジョブスケジューラーUGEによる実行」のスクリプト例の修正

2021/06/07 ソフトウェア配布前提で書かれていた3.3と3.5を削除(現在Schrodinerは学内配布しておらず、TSUBAME上でのみ実行でき

ます)

2020/04/30 X転送に関する記載を修正

2019/09/17 mkdocs版作成

2018/03/14 インタラクティブ実行にGUIの起動方法を追記

2017/09/15 初版
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